@angular-devkit/build-angular versions and peer dependencies

The table below has a list of all versions of @angular-devkit/build-angular compatible peers dependencies.

Version Peer Dependency Versions
0.1102.0
  • @angular/compiler-cli @ >=9.0.0 < 10
  • typescript @ >=3.6 < 3.9
0.901.14
  • @angular/compiler-cli @ >=9.0.0 < 10
  • typescript @ >=3.6 < 3.9
0.1002.2
  • @angular/compiler-cli @ ^10.0.0
  • @angular/localize @ ^10.0.0
  • ng-packagr @ ^10.0.0
  • typescript @ >=3.9 < 4.1
0.1101.3 - 0.1101.4
  • @angular/compiler-cli @ ^11.0.0
  • @angular/localize @ ^11.0.0
  • karma @ ^5.2.0
  • ng-packagr @ ^11.0.0
  • protractor @ ^7.0.0
  • tslint @ ^6.1.0
  • typescript @ ~4.0.0 || ~4.1.0
0.1101.0 - 0.1101.2
  • @angular/compiler-cli @ ^11.0.0 || ^11.1.0-next
  • @angular/localize @ ^11.0.0 || ^11.1.0-next
  • karma @ ^5.2.0
  • ng-packagr @ ^11.0.0 || ^11.1.0-next
  • protractor @ ^7.0.0
  • tslint @ ^6.1.0
  • typescript @ ~4.0.0 || ~4.1.0
0.1100.6 - 0.1100.7
  • @angular/compiler-cli @ ^11.0.0
  • @angular/localize @ ^11.0.0
  • karma @ ~5.1.0
  • ng-packagr @ ^11.0.0
  • protractor @ ^7.0.0
  • tslint @ ^6.1.0
  • typescript @ ~4.0.0
0.1002.1
  • @angular/compiler-cli @ ^10.0.0
  • @angular/localize @ ^10.0.0
  • ng-packagr @ ^10.0.0
  • typescript @ >=3.9 < 4.1
0.901.13
  • @angular/compiler-cli @ >=9.0.0 < 10
  • typescript @ >=3.6 < 3.9
0.1100.3 - 0.1100.5
  • @angular/compiler-cli @ ^11.0.0
  • @angular/localize @ ^11.0.0
  • karma @ ~5.1.0
  • ng-packagr @ ^11.0.0
  • protractor @ ^7.0.0
  • tslint @ ^6.1.0
  • typescript @ ~4.0.0
0.1100.0 - 0.1100.2
  • @angular/compiler-cli @ ^11.0.0 || ^11.0.0-next
  • @angular/localize @ ^11.0.0 || ^11.0.0-next
  • karma @ ~5.1.0
  • ng-packagr @ ^11.0.0 || ^11.0.0-next
  • protractor @ ^7.0.0
  • tslint @ ^6.1.0
  • typescript @ ~4.0.0
0.1001.1 - 0.1002.0
  • @angular/compiler-cli @ ^10.0.0
  • @angular/localize @ ^10.0.0
  • ng-packagr @ ^10.0.0
  • typescript @ >=3.9 < 4.1
0.1001.0
  • @angular/compiler-cli @ >=10.1.0-next.0 < 11
  • @angular/localize @ >=10.1.0-next.0 < 11
  • ng-packagr @ ^10.0.0
  • typescript @ >=3.9 < 4.1
0.1000.5 - 0.1000.8
  • @angular/compiler-cli @ >=10.0.0-next.0 < 11
  • typescript @ >=3.9 < 3.10
0.803.29
  • @angular/compiler-cli @ ^8.0.0
  • typescript @ >=3.1 < 3.6
0.901.12
  • @angular/compiler-cli @ >=9.0.0 < 10
  • typescript @ >=3.6 < 3.9
0.1000.3 - 0.1000.4
  • @angular/compiler-cli @ >=10.0.0-next.0 < 11
  • typescript @ >=3.9 < 3.10
0.901.11
  • @angular/compiler-cli @ >=9.0.0 < 10
  • typescript @ >=3.6 < 3.9
0.1000.2
  • @angular/compiler-cli @ >=10.0.0-next.0 < 11
  • typescript @ >=3.9 < 3.10
0.901.10
  • @angular/compiler-cli @ >=9.0.0 < 10
  • typescript @ >=3.6 < 3.9
0.1000.0 - 0.1000.1
  • @angular/compiler-cli @ >=10.0.0-next.0 < 11
  • typescript @ >=3.9 < 3.10
0.803.28
  • @angular/compiler-cli @ ^8.0.0
  • typescript @ >=3.1 < 3.6
0.901.9
  • @angular/compiler-cli @ >=9.0.0 < 10
  • typescript @ >=3.6 < 3.9
0.803.27
  • @angular/compiler-cli @ ^8.0.0
  • typescript @ >=3.1 < 3.6
0.901.1 - 0.901.8
  • @angular/compiler-cli @ >=9.0.0 < 10
  • typescript @ >=3.6 < 3.9
0.803.26
  • @angular/compiler-cli @ ^8.0.0
  • typescript @ >=3.1 < 3.6
0.901.0
  • @angular/compiler-cli @ >=9.0.0 < 10
  • typescript @ >=3.6 < 3.9
0.900.2 - 0.900.7
  • @angular/compiler-cli @ >=9.0.0 < 10
  • typescript @ >=3.6 < 3.8
0.900.0 - 0.900.1
  • @angular/compiler-cli @ >=9.0.0-beta < 10
  • typescript @ >=3.6 < 3.8
0.803.9 - 0.803.25
  • @angular/compiler-cli @ ^8.0.0
  • typescript @ >=3.1 < 3.6
0.802.0 - 0.803.8
  • @angular/compiler-cli @ ^8.0.0-beta.0 || ^8.1.0-beta.0 || ^8.2.0-beta.0 || ^8.3.0-beta.0 || ^8.4.0-beta.0 || >=9.0.0-beta < 9
  • typescript @ >=3.1 < 3.6
0.801.0 - 0.801.3
  • @angular/compiler-cli @ ^8.0.0-beta.0 || ^8.1.0-beta.0 || ^8.2.0-beta.0 || ^8.3.0-beta.0 || ^8.4.0-beta.0 || >=9.0.0-beta < 9
  • typescript @ >=3.1 < 3.5
0.800.4 - 0.800.6
  • @angular/compiler-cli @ >=8.0.0-beta.0 < 9.0.0
  • typescript @ >=3.1 < 3.5
0.800.0 - 0.800.3
  • typescript @ >=3.1 < 3.5