@azure/msal-angular versions and peer dependencies

The table below has a list of all versions of @azure/msal-angular compatible peers dependencies.

Version Peer Dependency Versions
0.1.0 - 0.1.4
  • @angular/common @ ^4.3.0
  • @angular/core @ ^4.3.0
  • rxjs @ ^5.0.1
1.0.0
  • @angular/common @ >= 6.0.0
  • @angular/core @ >= 6.0.0
  • msal @ ^1.3.0
  • rxjs @ ^6.0.0
  • tslib @ ^1.10.0
1.1.0
  • @angular/common @ >= 6.0.0
  • @angular/core @ >= 6.0.0
  • msal @ ^1.4.0
  • rxjs @ ^6.0.0
1.1.1
  • @angular/common @ >= 6.0.0
  • @angular/core @ >= 6.0.0
  • msal @ ^1.4.0
  • rxjs @ ^6.0.0
  • tslib @ ^1.10.0
1.1.2
  • @angular/common @ >= 6.0.0
  • @angular/core @ >= 6.0.0
  • msal @ ^1.4.0
  • rxjs @ ^6.0.0
  • tslib @ ^1.10.0
2.0.0
  • @azure/msal-browser @ ^2.14.2
  • rxjs @ ^6.0.0
2.0.1
  • @azure/msal-browser @ ^2.14.2
  • rxjs @ ^6.0.0