@ionic/angular versions and peer dependencies

The table below has a list of all versions of @ionic/angular compatible peers dependencies.

Version Peer Dependency Versions
4.0.0 - 4.6.2
  • @angular-devkit/core @ ^7.2.1
  • @angular-devkit/schematics @ ^7.2.1
  • @angular/core @ ^7.2.1
  • @angular/common @ ^7.2.1
  • @angular/forms @ ^7.2.1
  • @angular/router @ ^7.2.1
  • @angular/compiler @ ^7.2.1
  • @angular/compiler-cli @ ^7.2.1
  • @angular/platform-browser @ ^7.2.1
  • @angular/platform-browser-dynamic @ ^7.2.1
  • rxjs @ >=6.2.0
  • zone.js @ ^0.8.26
4.7.0 - 4.11.13
  • @angular-devkit/core @ 7.2.1 - 8
  • @angular-devkit/schematics @ 7.2.1 - 8
  • @angular/core @ 7.2.1 - 8
  • @angular/common @ 7.2.1 - 8
  • @angular/forms @ 7.2.1 - 8
  • @angular/router @ 7.2.1 - 8
  • @angular/compiler @ 7.2.1 - 8
  • @angular/compiler-cli @ 7.2.1 - 8
  • @angular/platform-browser @ 7.2.1 - 8
  • @angular/platform-browser-dynamic @ 7.2.1 - 8
  • rxjs @ >=6.2.0
  • zone.js @ >=0.8.26
5.0.0 - 5.6.3
  • @angular/core @ >=8.2.7
  • @angular/forms @ >=8.2.7
  • @angular/router @ >=8.2.7
  • rxjs @ >=6.2.0
  • zone.js @ >=0.8.26