@nestjs/mongoose versions and peer dependencies

The table below has a list of all versions of @nestjs/mongoose compatible peers dependencies.

Version Peer Dependency Versions
7.2.3
  • @nestjs/common @ ^6.0.0 || ^7.0.0
  • @nestjs/core @ ^6.0.0 || ^7.0.0
  • mongoose @ ^5.11.3
  • reflect-metadata @ ^0.1.12
  • rxjs @ ^6.0.0
7.2.0 - 7.2.2
  • @nestjs/common @ ^6.0.0 || ^7.0.0
  • @nestjs/core @ ^6.0.0 || ^7.0.0
  • mongoose @ ^5.11.3
  • reflect-metadata @ ^0.1.12
  • rxjs @ ^6.0.0
7.0.0 - 7.1.2
  • @nestjs/common @ ^6.0.0 || ^7.0.0
  • @nestjs/core @ ^6.0.0 || ^7.0.0
  • @types/mongoose @ ^5.0.0
  • mongoose @ ^5.4.19
  • reflect-metadata @ ^0.1.12
  • rxjs @ ^6.0.0
6.4.0
  • @nestjs/common @ ^6.0.0
  • @nestjs/core @ ^6.0.0
  • @types/mongoose @ ^5.0.0
  • mongoose @ ^5.4.19
  • reflect-metadata @ ^0.1.12
  • rxjs @ ^6.0.0
6.3.0 - 6.3.1
  • @nestjs/common @ ^6.0.0
  • @nestjs/core @ ^6.0.0
  • @types/mongoose @ ^5.0.0
  • mongoose @ ^5.4.19
  • reflect-metadata @ ^0.1.12
  • rxjs @ ^6.0.0
6.0.0 - 6.2.1
  • @nestjs/common @ ^6.0.0
  • @nestjs/core @ ^6.0.0
  • mongoose @ ^5.4.19
  • reflect-metadata @ ^0.1.12
  • rxjs @ ^6.0.0
5.1.0 - 5.2.2
  • @nestjs/common @ ^5.1.0
  • @nestjs/core @ ^5.1.0
  • mongoose @ ^5.0.1
  • reflect-metadata @ ^0.1.12
  • rxjs @ ^6.0.0
5.0.0
  • @nestjs/common @ ^5.0.0
  • mongoose @ ^5.0.1
  • reflect-metadata @ ^0.1.12
  • rxjs @ ^6.0.0
4.0.2
  • @nestjs/common @ ^5.0.0
  • mongoose @ ^5.0.1
  • rxjs @ ^6.0.0
4.0.0 - 4.0.1
  • @nestjs/common @ ^5.0.0
  • mongoose @ ^5.0.1
  • rxjs @ ^6.0.0
3.0.2
  • @nestjs/common @ ^4.5.0
  • mongoose @ ^5.0.1
3.0.0 - 3.0.1
  • @nestjs/common @ ^4.5.0
  • mongoose @ ^5.0.1
1.0.1 - 1.0.2
  • @nestjs/common @ ^4.3.0
  • mongoose @ ^4.11.13