@react-three/drei versions and peer dependencies

The table below has a list of all versions of @react-three/drei compatible peers dependencies.

Version Peer Dependency Versions
3.2.1 - 3.5.0
  • react @ >=17.0
  • react-dom @ >=17.0
  • react-three-fiber @ >=5.3.18
  • three @ >=0.125.0
3.0.0 - 3.2.0
  • react @ >=16.13
  • react-dom @ >=16.13
  • react-three-fiber @ >=5.0
  • three @ >=0.125.0
2.0.0 - 2.2.22
  • react @ >=16.13
  • react-dom @ >=16.13
  • react-three-fiber @ >=5.0
1.5.7 - 1.5.9
  • react @ >=16.13
  • react-dom @ >=16.13
  • react-three-fiber @ >=5.0