@swimlane/ngx-datatable versions and peer dependencies

The table below has a list of all versions of @swimlane/ngx-datatable compatible peers dependencies.

Version Peer Dependency Versions
4.0.0
  • @angular/common @ ^2.3.1
  • @angular/compiler @ ^2.3.1
  • @angular/core @ ^2.3.1
  • @angular/platform-browser @ ^2.3.1
  • @angular/platform-browser-dynamic @ ^2.3.1
  • zone.js @ ^0.7.2
  • rxjs @ ^5.0.1
  • core-js @ ^2.4.0
4.1.0
  • @angular/common @ ^2.4.1
  • @angular/compiler @ ^2.4.1
  • @angular/core @ ^2.4.1
  • @angular/platform-browser @ ^2.4.1
  • @angular/platform-browser-dynamic @ ^2.4.1
  • zone.js @ ^0.7.2
  • rxjs @ ^5.0.1
  • core-js @ ^2.4.0
4.2.0
  • @angular/common @ ^2.4.1
  • @angular/compiler @ ^2.4.1
  • @angular/core @ ^2.4.1
  • @angular/platform-browser @ ^2.4.1
  • @angular/platform-browser-dynamic @ ^2.4.1
  • zone.js @ ^0.7.2
  • rxjs @ ^5.0.1
  • core-js @ ^2.4.0
6.0.0
  • @angular/common @ ^2.4.4
  • @angular/compiler @ ^2.4.4
  • @angular/core @ ^2.4.4
  • @angular/platform-browser @ ^2.4.4
  • @angular/platform-browser-dynamic @ ^2.4.4
  • zone.js @ ^0.7.6
  • rxjs @ ^5.0.3
  • core-js @ ^2.4.0
6.0.1 - 6.0.2
  • @angular/common @ ^2.4.5
  • @angular/compiler @ ^2.4.5
  • @angular/core @ ^2.4.5
  • @angular/platform-browser @ ^2.4.5
  • @angular/platform-browser-dynamic @ ^2.4.5
  • zone.js @ ^0.7.6
  • rxjs @ ^5.0.3
  • core-js @ ^2.4.0
6.1.0 - 6.1.2
  • @angular/common @ ^2.4.7
  • @angular/compiler @ ^2.4.7
  • @angular/core @ ^2.4.7
  • @angular/platform-browser @ ^2.4.7
  • @angular/platform-browser-dynamic @ ^2.4.7
  • zone.js @ ^0.7.6
  • rxjs @ ^5.1.0
  • core-js @ ^2.4.0
6.2.0 - 6.3.0
  • @angular/common @ ^2.4.8
  • @angular/compiler @ ^2.4.8
  • @angular/core @ ^2.4.8
  • @angular/platform-browser @ ^2.4.8
  • @angular/platform-browser-dynamic @ ^2.4.8
  • zone.js @ ^0.7.7
  • rxjs @ ^5.1.0
  • core-js @ ^2.4.0
7.0.0
  • @angular/common @ ^4.0.0-rc.1
  • @angular/compiler @ ^4.0.0-rc.1
  • @angular/core @ ^4.0.0-rc.1
  • @angular/platform-browser @ ^4.0.0-rc.1
  • @angular/platform-browser-dynamic @ ^4.0.0-rc.1
  • zone.js @ ^0.7.7
  • rxjs @ ^5.1.0
  • core-js @ ^2.4.0
7.1.0 - 7.1.1
  • @angular/common @ ^4.0.0
  • @angular/compiler @ ^4.0.0
  • @angular/core @ ^4.0.0
  • @angular/platform-browser @ ^4.0.0
  • @angular/platform-browser-dynamic @ ^4.0.0
  • rxjs @ ^5.1.0
  • core-js @ ^2.4.0
7.2.0 - 7.3.0
  • @angular/common @ ^4.0.0
  • @angular/compiler @ ^4.0.0
  • @angular/core @ ^4.0.0
  • @angular/platform-browser @ ^4.0.0
  • @angular/platform-browser-dynamic @ ^4.0.0
  • core-js @ ^2.4.0
  • rxjs @ ^5.0.0
8.0.0 - 8.2.1
  • @angular/common @ ^4.0.0
  • @angular/compiler @ ^4.0.0
  • @angular/core @ ^4.0.0
  • @angular/platform-browser @ ^4.0.0
  • @angular/platform-browser-dynamic @ ^4.0.0
  • core-js @ ^2.4.0
  • rxjs @ ^5.0.0
9.0.0 - 9.3.1
  • @angular/common @ ^4.0.0
  • @angular/compiler @ ^4.0.0
  • @angular/core @ ^4.0.0
  • @angular/platform-browser @ ^4.0.0
  • @angular/platform-browser-dynamic @ ^4.0.0
  • core-js @ ^2.4.0
  • rxjs @ ^5.0.0
10.0.0 - 10.5.0
  • @angular/common @ ^4.0.0
  • @angular/compiler @ ^4.0.0
  • @angular/core @ ^4.0.0
  • @angular/platform-browser @ ^4.0.0
  • @angular/platform-browser-dynamic @ ^4.0.0
  • core-js @ ^2.4.0
  • rxjs @ ^5.0.0
11.0.0
  • @angular/common @ ^4.0.0
  • @angular/compiler @ ^4.0.0
  • @angular/core @ ^4.0.0
  • @angular/platform-browser @ ^4.0.0
  • @angular/platform-browser-dynamic @ ^4.0.0
  • core-js @ ^2.4.0
  • rxjs @ ^5.0.0
11.0.1 - 11.1.4
  • @angular/common @ ^5.0.0
  • @angular/compiler @ ^5.0.0
  • @angular/core @ ^5.0.0
  • @angular/platform-browser @ ^5.0.0
  • @angular/platform-browser-dynamic @ ^5.0.0
  • core-js @ ^2.4.0
  • rxjs @ ^5.0.0
11.1.5 - 11.3.0
  • @angular/common @ >=4.0.1 || >5.0.0
  • @angular/compiler @ >=4.0.1 || >5.0.0
  • @angular/core @ >=4.0.1 || >5.0.0
  • @angular/platform-browser @ >=4.0.1 || >5.0.0
  • @angular/platform-browser-dynamic @ >=4.0.1 || >5.0.0
  • core-js @ ^2.4.0
  • rxjs @ ^5.0.0
11.3.1 - 11.3.2
  • @angular/common @ >=4.0.1 || >5.0.0 || <=6.0.0
  • @angular/compiler @ >=4.0.1 || >5.0.0 || <=6.0.0
  • @angular/core @ >=4.0.1 || >5.0.0 || <=6.0.0
  • @angular/platform-browser @ >=4.0.1 || >5.0.0 || <=6.0.0
  • @angular/platform-browser-dynamic @ >=4.0.1 || >5.0.0 || <=6.0.0
  • core-js @ ^2.4.0
  • rxjs @ ^5.0.0
13.0.0 - 13.1.0
  • @angular/common @ <7.0.0
  • @angular/compiler @ <7.0.0
  • @angular/core @ <7.0.0
  • @angular/platform-browser @ <7.0.0
  • @angular/platform-browser-dynamic @ <7.0.0
  • core-js @ ^2.4.0
  • rxjs @ ^6.0.0
15.0.0 - 15.0.2
  • @angular/common @ <9.0.0
  • @angular/compiler @ <9.0.0
  • @angular/core @ <9.0.0
  • @angular/platform-browser @ <9.0.0
  • @angular/platform-browser-dynamic @ <9.0.0
  • rxjs @ 6.x
16.0.0 - 16.0.3
  • @angular/common @ <9.0.0
  • @angular/core @ <9.0.0
  • @angular/platform-browser @ <9.0.0
  • rxjs @ ^6.5.2
16.1.0
  • @angular/common @ 7.x || 8.x || 9.x
  • @angular/core @ 7.x || 8.x || 9.x
  • @angular/platform-browser @ 7.x || 8.x || 9.x
  • rxjs @ ~6.5.5
  • tslib @ ^1.10.0
16.1.1
  • @angular/common @ 7.x || 8.x || 9.x
  • @angular/core @ 7.x || 8.x || 9.x
  • @angular/platform-browser @ 7.x || 8.x || 9.x
  • rxjs @ ~6.5.5
  • tslib @ ^1.10.0
17.0.0 - 17.1.0
  • @angular/common @ ~9.1.0
  • @angular/core @ ~9.1.0
  • @angular/platform-browser @ ~9.1.0
  • rxjs @ ~6.5.5
  • tslib @ ^1.10.0