connected-react-router versions and peer dependencies

The table below has a list of all versions of connected-react-router compatible peers dependencies.

Version Peer Dependency Versions
4.0.0
  • react @ ^15.0.0
  • react-redux @ ^4.4.6 || ^5.0.0
  • redux @ ^3.6.0
4.1.0 - 4.2.3
  • react @ ^15.5.4
  • react-redux @ ^4.4.8 || ^5.0.4
  • redux @ ^3.6.0
4.3.0
  • react @ ^15.5.4 || ^16.0.0
  • react-redux @ ^4.4.8 || ^5.0.4
  • redux @ ^3.6.0
4.4.0 - 4.5.0
  • react @ ^15.5.4 || ^16.0.0
  • react-redux @ ^4.4.8 || ^5.0.7
  • react-router @ ^4.3.1
  • redux @ ^3.6.0 || ^4.0.0
5.0.0
  • react @ ^15.5.4 || ^16.0.0
  • react-redux @ ^4.4.8 || ^5.0.7
  • react-router @ ^4.3.1
  • redux @ ^3.6.0 || ^4.0.0
5.0.1
  • react @ ^15.5.4 || ^16.0.0
  • react-redux @ ^4.4.8 || ^5.0.7
  • react-router @ ^4.3.1
  • redux @ ^3.6.0 || ^4.0.0
6.0.0 - 6.3.1
  • history @ ^4.7.2
  • react @ ^16.4.0
  • react-redux @ ^6.0.0
  • react-router @ ^4.3.1
  • redux @ ^3.6.0 || ^4.0.0
6.3.2
  • history @ ^4.7.2
  • prop-types @ ^15.0.0 || ^16.0.0
  • react @ ^16.4.0
  • react-redux @ ^6.0.0
  • react-router @ ^4.3.1
  • redux @ ^3.6.0 || ^4.0.0
6.4.0
  • history @ ^4.7.2
  • react @ ^16.4.0
  • react-redux @ ^6.0.0
  • react-router @ ^4.3.1 || ^5.0.0
  • redux @ ^3.6.0 || ^4.0.0
6.5.0 - 6.6.1
  • history @ ^4.7.2
  • react @ ^16.4.0
  • react-redux @ ^6.0.0 || ^7.1.0
  • react-router @ ^4.3.1 || ^5.0.0
  • redux @ ^3.6.0 || ^4.0.0
6.7.0 - 6.8.0
  • immutable @ ^3.8.1 || ^4.0.0-rc.1
  • history @ ^4.7.2
  • react @ ^16.4.0
  • react-redux @ ^6.0.0 || ^7.1.0
  • react-router @ ^4.3.1 || ^5.0.0
  • redux @ ^3.6.0 || ^4.0.0
  • seamless-immutable @ ^7.1.3
6.9.0
  • immutable @ ^3.8.1 || ^4.0.0-rc.1
  • history @ ^4.7.2
  • react @ ^16.4.0
  • react-redux @ ^6.0.0 || ^7.1.0
  • react-router @ ^4.3.1 || ^5.0.0
  • redux @ ^3.6.0 || ^4.0.0
  • seamless-immutable @ ^7.1.3