eslint-config-react-app versions and peer dependencies

The table below has a list of all versions of eslint-config-react-app compatible peers dependencies.

Version Peer Dependency Versions
0.1.0
  • babel-eslint @ 6.1.2
  • eslint @ 3.5.0
  • eslint-plugin-flowtype @ 2.18.1
  • eslint-plugin-import @ 1.12.0
  • eslint-plugin-jsx-a11y @ 2.2.2
  • eslint-plugin-react @ 5.2.2
0.2.0 - 0.2.1
  • babel-eslint @ 6.1.2
  • eslint @ 3.5.0
  • eslint-plugin-flowtype @ 2.18.1
  • eslint-plugin-import @ 1.12.0
  • eslint-plugin-jsx-a11y @ 2.2.2
  • eslint-plugin-react @ 6.3.0
0.3.0 - 0.4.0
  • babel-eslint @ 7.0.0
  • eslint @ 3.8.1
  • eslint-plugin-flowtype @ 2.21.0
  • eslint-plugin-import @ 2.0.1
  • eslint-plugin-jsx-a11y @ 2.2.3
  • eslint-plugin-react @ 6.4.1
0.5.0 - 0.5.2
  • babel-eslint @ ^7.0.0
  • eslint @ ^3.8.1
  • eslint-plugin-flowtype @ ^2.21.0
  • eslint-plugin-import @ ^2.0.1
  • eslint-plugin-jsx-a11y @ ^2.2.3
  • eslint-plugin-react @ ^6.4.1
0.6.0
  • babel-eslint @ ^7.0.0
  • eslint @ ^3.16.1
  • eslint-plugin-flowtype @ ^2.21.0
  • eslint-plugin-import @ ^2.0.1
  • eslint-plugin-jsx-a11y @ ^4.0.0
  • eslint-plugin-react @ ^6.4.1
0.6.1 - 0.6.2
  • babel-eslint @ ^7.0.0
  • eslint @ ^3.16.1
  • eslint-plugin-flowtype @ ^2.21.0
  • eslint-plugin-import @ ^2.0.1
  • eslint-plugin-jsx-a11y @ ^2.0.0 || ^3.0.0 || ^4.0.0
  • eslint-plugin-react @ ^6.4.1
1.0.0 - 1.0.3
  • babel-eslint @ ^7.2.3
  • eslint @ ^3.19.0
  • eslint-plugin-flowtype @ ^2.33.0
  • eslint-plugin-import @ ^2.2.0
  • eslint-plugin-jsx-a11y @ ^5.0.1
  • eslint-plugin-react @ ^7.0.1
1.0.4 - 1.0.5
  • babel-eslint @ ^7.2.3
  • eslint @ ^3.19.0
  • eslint-plugin-flowtype @ ^2.33.0
  • eslint-plugin-import @ ^2.2.0
  • eslint-plugin-jsx-a11y @ ^5.0.3
  • eslint-plugin-react @ ^7.0.1
2.0.0 - 2.1.0
  • babel-eslint @ ^7.2.3
  • eslint @ ^4.1.1
  • eslint-plugin-flowtype @ ^2.34.1
  • eslint-plugin-import @ ^2.6.0
  • eslint-plugin-jsx-a11y @ ^5.1.1
  • eslint-plugin-react @ ^7.1.0
3.0.0 - 3.0.8
  • babel-eslint @ 9.x
  • eslint @ 5.x
  • eslint-plugin-flowtype @ 2.x
  • eslint-plugin-import @ 2.x
  • eslint-plugin-jsx-a11y @ 6.x
  • eslint-plugin-react @ 7.x
4.0.0 - 4.0.1
  • @typescript-eslint/eslint-plugin @ 1.x
  • @typescript-eslint/parser @ 1.x
  • babel-eslint @ 10.x
  • eslint @ 5.x
  • eslint-plugin-flowtype @ 2.x
  • eslint-plugin-import @ 2.x
  • eslint-plugin-jsx-a11y @ 6.x
  • eslint-plugin-react @ 7.x
  • eslint-plugin-react-hooks @ 1.x
5.0.0 - 5.0.1
  • @typescript-eslint/eslint-plugin @ 1.x
  • @typescript-eslint/parser @ 1.x
  • babel-eslint @ 10.x
  • eslint @ 6.x
  • eslint-plugin-flowtype @ 3.x
  • eslint-plugin-import @ 2.x
  • eslint-plugin-jsx-a11y @ 6.x
  • eslint-plugin-react @ 7.x
  • eslint-plugin-react-hooks @ 1.x
5.0.2 - 5.2.0
  • @typescript-eslint/eslint-plugin @ 2.x
  • @typescript-eslint/parser @ 2.x
  • babel-eslint @ 10.x
  • eslint @ 6.x
  • eslint-plugin-flowtype @ 3.x
  • eslint-plugin-import @ 2.x
  • eslint-plugin-jsx-a11y @ 6.x
  • eslint-plugin-react @ 7.x
  • eslint-plugin-react-hooks @ 1.x
5.2.1
  • @typescript-eslint/eslint-plugin @ 2.x
  • @typescript-eslint/parser @ 2.x
  • babel-eslint @ 10.x
  • eslint @ 6.x
  • eslint-plugin-flowtype @ 3.x
  • eslint-plugin-import @ 2.x
  • eslint-plugin-jsx-a11y @ 6.x
  • eslint-plugin-react @ 7.x
  • eslint-plugin-react-hooks @ 1.x