karma-webpack versions and peer dependencies

The table below has a list of all versions of karma-webpack compatible peers dependencies.

Version Peer Dependency Versions
1.0.0 - 1.0.1
  • webpack @ 1.x
  • webpack-dev-server @ 1.x
  • karma @ >=0.9
1.0.2
  • webpack @ 1.x
  • webpack-dev-server @ 1.x
  • karma @ >=0.9 <0.12
1.1.0
  • webpack @ 1.x
  • webpack-dev-server @ 1.x
  • karma @ >=0.12 < 1
1.2.1 - 1.2.2
  • webpack @ ^1.2.0-beta5
  • webpack-dev-server @ 1.x
  • karma @ >=0.12 < 1
1.3.0 - 1.3.1
  • webpack @ ^1.2.0-beta5
  • webpack-dev-server @ ^1.0.0
  • karma @ >=0.12 < 1
1.4.0
  • webpack @ ^1.4.0
  • webpack-dev-server @ ^1.0.0
  • karma @ >=0.12 < 1
1.5.0 - 1.5.1
  • webpack @ ^1.4.0
  • karma @ >=0.12 < 1
1.6.0 - 1.7.0
  • webpack @ ^1.4.0
1.8.0
  • webpack @ ^1.1.0 || ^2 || ^2.1.0-beta
1.8.1
  • webpack @ ^1.1.0 || ^2 || ^2.1.0-beta
2.0.0 - 2.0.3
  • webpack @ ^1.1.0 || ^2 || ^2.1.0-beta.0 || ^2.2.0-rc.0
2.0.4 - 2.0.9
  • webpack @ ^1.0.0 || ^2.0.0 || ^3.0.0
2.0.10 - 2.0.13
  • webpack @ ^1.0.0 || ^2.0.0 || ^3.0.0 || ^4.0.0
3.0.0
  • webpack @ ^2.2.0 || ^3.0.0 || ^4.0.0
3.0.1 - 3.0.5
  • webpack @ ^2.0.0 || ^3.0.0
4.0.0 - 4.0.2
  • webpack @ ^4.0.0