mobx-react-lite versions and peer dependencies

The table below has a list of all versions of mobx-react-lite compatible peers dependencies.

Version Peer Dependency Versions
0.1.0 - 0.3.0
  • mobx @ ^5.0.0
  • react @ ^16.7.0-alpha.0
0.3.1 - 0.3.4
  • mobx @ ^4.0.0 || ^5.0.0
  • react @ ^16.7.0-alpha.0
0.3.5 - 0.3.7
  • mobx @ ^4.0.0 || ^5.0.0
  • react @ 16.7.0-alpha.2 || 16.8.0-alpha.0
1.0.0 - 1.5.2
  • mobx @ ^4.0.0 || ^5.0.0
  • react @ ^16.8.0
2.0.0 - 2.2.2
  • mobx @ ^4.0.0 || ^5.0.0
  • react @ ^16.8.0
3.0.0 - 3.1.0
  • mobx @ ^6.0.0
  • react @ ^16.8.0
3.1.1 - 3.1.5
  • mobx @ ^6.0.0
  • react @ ^16.8.0 || ^17
3.1.6
  • mobx @ ^6.0.4
  • react @ ^16.8.0 || ^17
3.1.7
  • mobx @ ^6.0.5
  • react @ ^16.8.0 || ^17
3.2.0
  • mobx @ ^6.0.5
  • react @ ^16.8.0 || ^17