ng-zorro-antd versions and peer dependencies

The table below has a list of all versions of ng-zorro-antd compatible peers dependencies.

Version Peer Dependency Versions
0.5.0
  • @angular/animations @ ^4.0.0
  • @angular/cdk @ ^2.0.0-beta.8
  • @angular/common @ ^4.0.0
  • @angular/core @ ^4.0.0
  • @angular/forms @ ^4.0.0
  • moment @ ^2.18.1
0.5.1 - 0.5.5
  • @angular/animations @ ^4.0.0
  • @angular/cdk @ 2.0.0-beta.8
  • @angular/common @ ^4.0.0
  • @angular/core @ ^4.0.0
  • @angular/forms @ ^4.0.0
  • moment @ ^2.18.1
0.6.0 - 0.6.2
  • @angular/animations @ ^5.0.0
  • @angular/cdk @ 5.0.0-rc0
  • @angular/common @ ^5.0.0
  • @angular/core @ ^5.0.0
  • @angular/forms @ ^5.0.0
  • moment @ ^2.18.1
0.6.3
  • @angular/animations @ ^5.0.0
  • @angular/cdk @ 5.0.0-rc.3
  • @angular/common @ ^5.0.0
  • @angular/core @ ^5.0.0
  • @angular/forms @ ^5.0.0
  • moment @ ^2.18.1
0.6.6
  • @angular/animations @ ^5.0.0
  • @angular/cdk @ 5.0.0
  • @angular/common @ ^5.0.0
  • @angular/core @ ^5.0.0
  • @angular/forms @ ^5.0.0
  • moment @ ^2.18.1
0.6.7 - 0.6.15
  • @angular/animations @ ^5.0.0
  • @angular/cdk @ ^5.0.0
  • @angular/common @ ^5.0.0
  • @angular/core @ ^5.0.0
  • @angular/forms @ ^5.0.0
  • moment @ ^2.18.1
0.7.0 - 0.7.1
  • @angular/animations @ ^5.0.0
  • @angular/cdk @ ^5.0.0
  • @angular/common @ ^5.0.0
  • @angular/core @ ^5.0.0
  • @angular/forms @ ^5.0.0
1.0.0 - 1.5.0
  • @angular/animations @ ^6.0.0
  • @angular/cdk @ ^6.0.0
  • @angular/common @ ^6.0.0
  • @angular/core @ ^6.0.0
  • @angular/forms @ ^6.0.0
1.6.0 - 1.8.1
  • @angular/animations @ ^6.0.0
  • @angular/cdk @ ^6.0.0
  • @angular/common @ ^6.0.0
  • @angular/core @ ^6.0.0
  • @angular/forms @ ^6.0.0
  • tslib @ ^1.9.0
  • typescript @ ~2.9.2
7.0.0 - 7.5.1
  • @angular/animations @ ^7.0.0
  • @angular/cdk @ ^7.3.0
  • @angular/common @ ^7.0.0
  • @angular/core @ ^7.0.0
  • @angular/forms @ ^7.0.0
8.0.0 - 8.0.1
  • @angular/animations @ ~8.0.0
  • @angular/cdk @ ~8.0.0
  • @angular/common @ ~8.0.0
  • @angular/core @ ~8.0.0
  • @angular/forms @ ~8.0.0
8.0.2
  • @angular/animations @ ^8.0.0
  • @angular/cdk @ ^8.0.0
  • @angular/common @ ^8.0.0
  • @angular/core @ ^8.0.0
  • @angular/forms @ ^8.0.0
8.0.3 - 8.1.2
  • @angular/animations @ ^8.0.0
  • @angular/common @ ^8.0.0
  • @angular/core @ ^8.0.0
  • @angular/forms @ ^8.0.0
8.2.0 - 8.3.1
  • @angular/animations @ ^8.0.0
  • @angular/common @ ^8.0.0
  • @angular/core @ ^8.0.0
  • @angular/platform-browser @ ^8.0.0
  • @angular/router @ ^8.0.0
  • rxjs @ ^6.5.2
8.4.0 - 8.5.2
  • @angular/animations @ ^8.0.0
  • @angular/common @ ^8.0.0
  • @angular/core @ ^8.0.0
  • @angular/platform-browser @ ^8.0.0
  • @angular/router @ ^8.0.0
  • rxjs @ ^6.4.0
9.0.0 - 9.1.2
  • @angular/animations @ ^9.0.0
  • @angular/common @ ^9.0.0
  • @angular/forms @ ^9.0.0
  • @angular/core @ ^9.0.0
  • @angular/platform-browser @ ^9.0.0
  • @angular/router @ ^9.0.0
  • rxjs @ ~6.5.3
  • tslib @ ^1.10.0
9.2.0 - 9.3.0
  • @angular/animations @ ^9.0.0
  • @angular/common @ ^9.0.0
  • @angular/forms @ ^9.0.0
  • @angular/core @ ^9.0.0
  • @angular/platform-browser @ ^9.0.0
  • @angular/router @ ^9.0.0
  • rxjs @ ~6.5.3
10.0.0 - 10.2.2
  • @angular/animations @ ^10.0.0
  • @angular/common @ ^10.0.0
  • @angular/forms @ ^10.0.0
  • @angular/core @ ^10.0.0
  • @angular/platform-browser @ ^10.0.0
  • @angular/router @ ^10.0.0
11.0.0 - 11.4.2
  • @angular/animations @ ^11.0.4
  • @angular/common @ ^11.0.4
  • @angular/forms @ ^11.0.4
  • @angular/core @ ^11.0.4
  • @angular/platform-browser @ ^11.0.4
  • @angular/router @ ^11.0.4