react-beautiful-dnd versions and peer dependencies

The table below has a list of all versions of react-beautiful-dnd compatible peers dependencies.

Version Peer Dependency Versions
1.0.0 - 1.0.3
  • react @ 15.6.1
2.0.0 - 2.1.1
  • react @ 15.6.1
2.2.0 - 2.6.2
  • react @ >=15.4.0
4.0.0 - 4.0.1
  • react @ >=15.4.0 || ^16.0.0
6.0.0 - 6.0.2
  • react @ >=15.4.0 || ^16.0.0
7.0.0 - 7.1.3
  • react @ ^16.3.1
8.0.0 - 8.0.7
  • react @ ^16.3.1
9.0.0 - 9.0.2
  • react @ ^16.3.1
10.0.0 - 10.1.1
  • react @ ^16.3.1
11.0.0 - 11.0.5
  • react @ ^16.8.5
12.0.0 - 12.2.0
  • react @ ^16.8.5
  • react-dom @ ^16.8.5