react-datepicker versions and peer dependencies

The table below has a list of all versions of react-datepicker compatible peers dependencies.

Version Peer Dependency Versions
3.0.0 - 3.4.1
  • react @ ^16.9.0
  • react-dom @ ^16.9.0
2.9.0 - 2.16.0
  • react @ ^16.9.0
  • react-dom @ ^16.9.0
2.0.0 - 2.8.0
  • react @ ^16.0.0
  • react-dom @ ^16.0.0
1.2.1 - 1.8.0
  • moment @ ^2.20.0
  • react @ ^16.0.0
  • react-dom @ ^16.0.0
1.0.0 - 1.1.0
  • moment @ ^2.0.0
  • react @ ^16.0.0
  • react-dom @ ^16.0.0
0.64.0
  • react @ ^16.0.0
  • react-dom @ ^16.0.0
0.61.0 - 0.63.0
  • react @ ^16.0.0
  • react-dom @ ^16.0.0
0.57.0 - 0.60.2
  • react @ ^0.14.0 || ^15.0.0 || ^16.0.0
  • react-dom @ ^0.14.0 || ^15.0.0 || ^16.0.0
0.27.0 - 0.56.0
  • react @ ^0.14.0 || ^15.0.0
  • react-dom @ ^0.14.0 || ^15.0.0
0.14.5 - 0.26.0
  • react @ ^0.14.0
0.14.0 - 0.14.4
  • react @ >=0.12 <0.15
0.6.0 - 0.13.0
  • react @ >=0.12 <0.14