react-dates versions and peer dependencies

The table below has a list of all versions of react-dates compatible peers dependencies.

Version Peer Dependency Versions
2.0.0 - 2.1.0
  • jquery @ >=2.1
  • moment @ >=2.10
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
2.1.1
  • moment @ >=2.10
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
2.2.0
  • moment @ >=2.10
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
3.0.0
  • moment @ >=2.10 && < 2.15.0
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
3.1.0
  • moment @ 2.10-2.14 || ^2.15.1
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
3.1.1 - 3.6.0
  • moment @ 2.10 - 2.14 || ^2.15.1
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
4.0.0 - 4.3.3
  • moment @ 2.10 - 2.14 || ^2.15.1
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
5.0.0 - 5.2.0
  • moment @ 2.10 - 2.14 || ^2.15.1
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
6.0.0 - 6.1.0
  • moment @ 2.10 - 2.14 || ^2.15.1
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
7.0.0 - 7.0.1
  • moment @ 2.10 - 2.14 || ^2.15.1
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
8.0.0 - 8.2.1
  • moment @ 2.10 - 2.14 || ^2.15.1
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
9.0.0 - 9.0.1
  • moment @ (2.10 - 2.14 || ^2.15.1) && < 2.18.0
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
10.0.0 - 10.1.3
  • moment @ (2.10 - 2.14 || ^2.15.1) && < 2.18.0
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
11.0.0
  • moment @ (2.10 - 2.14 || ^2.15.1) && < 2.18.0
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
11.0.1 - 11.1.0
  • moment @ 2.10 - 2.14 || ~2.15.1 || ~2.16 || ~2.17
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
12.0.0 - 12.7.1
  • moment @ ^2.18.1
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
13.0.0 - 13.0.6
  • moment @ ^2.18.1
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
14.0.0 - 14.1.0
  • moment @ ^2.18.1
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
15.0.0 - 15.1.0
  • moment @ ^2.18.1
  • react @ >=0.14
  • react-dom @ >=0.14
  • react-addons-shallow-compare @ >=0.14
15.2.0 - 15.5.3
  • moment @ ^2.18.1
  • react @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-dom @ ^0.14 || ^15.5.4 || ^16.1.1
16.0.0 - 16.7.0
  • moment @ ^2.18.1
  • react @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-dom @ ^0.14 || ^15.5.4 || ^16.1.1
16.7.1
  • moment @ ^2.18.1
  • react @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-dom @ ^0.14 || ^15.5.4 || ^16.1.1
17.0.0 - 17.2.0
  • moment @ ^2.18.1
  • react @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-dom @ ^0.14 || ^15.5.4 || ^16.1.1
18.0.0
  • moment @ ^2.18.1
  • react @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-dom @ ^0.14 || ^15.5.4 || ^16.1.1
18.0.1 - 18.5.0
  • moment @ ^2.18.1
  • react @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-dom @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-with-direction @ ^1.3.0
19.0.0 - 19.0.4
  • moment @ ^2.18.1
  • react @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-dom @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-with-direction @ ^1.3.0
20.0.0 - 20.3.0
  • moment @ ^2.18.1
  • react @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-dom @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-with-direction @ ^1.3.0
21.0.0 - 21.8.0
  • @babel/runtime @ ^7.0.0
  • moment @ ^2.18.1
  • react @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-dom @ ^0.14 || ^15.5.4 || ^16.1.1
  • react-with-direction @ ^1.3.1