react-relay versions and peer dependencies

The table below has a list of all versions of react-relay compatible peers dependencies.

Version Peer Dependency Versions
0.1.1 - 0.2.1
  • react @ ^0.14.0-beta3
0.3.0 - 0.3.2
  • react @ ^0.14.0-rc
  • react-dom @ ^0.14.0-rc
0.4.0
  • react @ ^0.14.0
  • react-dom @ ^0.14.0
0.5.0
  • babel-relay-plugin @ ^0.4.1
  • react @ ^0.14.0
  • react-dom @ ^0.14.0
0.6.0
  • babel-relay-plugin @ 0.6.0
  • react @ ^0.14.0
  • react-dom @ ^0.14.0
0.6.1
  • babel-relay-plugin @ 0.6.3
  • react @ ^0.14.0
  • react-dom @ ^0.14.0
0.7.0
  • babel-relay-plugin @ 0.7.0
  • react @ ^0.14.0
0.7.1
  • babel-relay-plugin @ 0.7.1
  • react @ ^0.14.0
0.7.2
  • babel-relay-plugin @ 0.7.2
  • react @ ^0.14.0
0.7.3
  • babel-relay-plugin @ 0.7.3
  • react @ ^0.14.0
0.8.0
  • babel-relay-plugin @ 0.8.0
  • react @ ^15.0.0 || ^0.14.0
0.8.1
  • babel-relay-plugin @ 0.8.1
  • react @ ^15.0.0 || ^0.14.0
0.9.0
  • babel-relay-plugin @ 0.9.0
  • react @ ^15.0.0 || ^0.14.0
0.9.1
  • babel-relay-plugin @ 0.9.1
  • react @ ^15.0.0 || ^0.14.0
0.9.2
  • babel-relay-plugin @ 0.9.2
  • react @ ^15.0.0 || ^0.14.0
0.9.3
  • babel-relay-plugin @ 0.9.3
  • react @ ^15.0.0 || ^0.14.0
0.10.0
  • babel-relay-plugin @ 0.9.3
  • react @ ^15.0.0 || ^0.14.0
1.0.0 - 1.5.0
  • react @ ^16.0.0-a || ^15.0.0 || ^0.14.0
1.6.0 - 1.7.0
  • react @ ^16.3.0
7.0.0 - 7.1.0
  • react @ ^16.9.0
9.0.0 - 9.1.0
  • react @ ^16.9.0
10.0.0 - 10.0.1
  • react @ ^16.9.0
10.1.0 - 10.1.3
  • react @ ^16.9.0 || ^17
11.0.0 - 11.0.1
  • react @ ^16.9.0 || ^17