react-router versions and peer dependencies

The table below has a list of all versions of react-router compatible peers dependencies.

Version Peer Dependency Versions
5.0.0 - 5.2.0
  • react @ >=15
4.2.0 - 4.3.1
  • react @ >=15
4.0.0 - 4.1.2
  • react @ ^15
3.2.1 - 3.2.6
  • react @ ^0.14.0 || ^15.0.0 || ^16.0.0
3.2.0
  • react @ ^0.14.0 || ^15.0.0 || ^16.0.0-rc
3.0.0 - 3.0.5
  • react @ ^0.14.0 || ^15.0.0
2.4.0 - 2.8.1
  • react @ ^0.14.0 || ^15.0.0
1.0.3
  • history @ 1.13.x
1.0.2
  • history @ 1.13.x
1.0.0 - 1.0.1
  • history @ ^1.12.0
0.13.6
  • react @ 0.13.x||0.14.x
0.13.5
  • react @ 0.13.x||0.14.x
0.13.0 - 0.13.4
  • react @ 0.13.x
0.10.0 - 0.12.4
  • react @ 0.12.x
0.9.5
  • react @ 0.11.x
0.4.0 - 0.9.4
  • react @ >=0.11.0