react-scroll versions and peer dependencies

The table below has a list of all versions of react-scroll compatible peers dependencies.

Version Peer Dependency Versions
1.5.5 - 1.8.1
  • react @ ^15.5.4 || ^16.0.0
  • react-dom @ ^15.5.4 || ^16.0.0
1.5.1 - 1.5.4
  • react @ ^15.5.4
  • react-dom @ ^15.5.4
1.3.1 - 1.5.0
  • react @ ^15.0.1
  • react-dom @ ^15.0.1
1.0.0 - 1.0.12
  • react @ >=0.13.0
0.26.0 - 0.36.0
  • react @ >=0.13.0
0.15.0 - 0.23.0
  • react @ >=0.12.0
0.0.1 - 0.14.0
  • react @ 0.12.x