react-three-fiber versions and peer dependencies

The table below has a list of all versions of react-three-fiber compatible peers dependencies.

Version Peer Dependency Versions
5.1.0 - 5.3.18
  • react @ >=17.0
  • react-dom @ >=17.0
  • three @ >=0.121
5.0.1 - 5.0.6
  • react @ >=16.13
  • react-dom @ >=16.13
  • three @ >=0.115
5.0.0
  • react @ >=17.0-rc.0
  • react-dom @ >=17.0-rc.0
  • three @ >=0.120
4.0.24 - 4.2.21
  • react @ >=16.13
  • react-dom @ >=16.13
  • three @ >=0.115
4.0.21 - 4.0.23
  • react @ >=16.13
  • react-dom @ >=16.13
  • three @ >=0.114
4.0.16 - 4.0.20
  • react @ >=16.12
  • react-dom @ >=16.12
  • three @ >=0.113
4.0.1 - 4.0.14
  • react @ >=16.12
  • react-dom @ >=16.12
  • three @ >=0.112
3.0.8 - 3.0.17
  • react @ >=16.11
  • react-dom @ >=16.11
  • three @ >=0.110
3.0.6 - 3.0.7
  • react @ >=16.11
  • react-dom @ >=16.11
  • three @ >=0.109
3.0.0 - 3.0.3
  • react @ >=16.9
  • react-dom @ >=16.9
  • three @ >=0.108
2.3.0 - 2.4.3
  • react @ >=16.9
  • react-dom @ >=16.9
  • three @ >=0.107
2.0.10 - 2.2.17
  • react @ >=16.8
  • react-dom @ >=16.8
  • three @ >=0.103
2.0.0 - 2.0.9
  • react @ >=16.8
  • react-dom @ >=16.8
  • three @ >=0.100
1.3.5 - 1.5.3
  • react @ >=16.8
  • react-dom @ >=16.8
  • three @ >=0.100
1.0.2 - 1.3.4
  • react @ >=16.8
  • react-dom @ >=16.8
  • three @ >=100