reactstrap versions and peer dependencies

The table below has a list of all versions of reactstrap compatible peers dependencies.

Version Peer Dependency Versions
0.5.0 - 0.8.0
  • react @ >=0.14.0 || >=15.0.0-rc.1
  • react-dom @ >=0.14.0 || >=15.0.0-rc.1
1.0.0 - 1.2.4
  • react @ >=0.14.0 || >=15.0.0-rc.1
  • react-dom @ >=0.14.0 || >=15.0.0-rc.1
1.3.0
  • react @ >=0.14.0 || >=15.0.0-rc.1
  • react-addons-transition-group @ >=0.14.0 || >=15.0.0-rc.1
  • react-dom @ >=0.14.0 || >=15.0.0-rc.1
1.3.1 - 1.6.1
  • react @ ^0.14.0 || ^15.0.0
  • react-addons-transition-group @ ^0.14.0 || ^15.0.0
  • react-dom @ ^0.14.0 || ^15.0.0
2.0.0 - 2.6.1
  • react @ ^0.14.0 || ^15.0.0
  • react-addons-transition-group @ ^0.14.0 || ^15.0.0
  • react-dom @ ^0.14.0 || ^15.0.0
3.0.0 - 3.3.2
  • react @ ^0.14.0 || ^15.0.0
  • react-addons-transition-group @ ^0.14.0 || ^15.0.0
  • react-dom @ ^0.14.0 || ^15.0.0
3.4.0 - 3.9.5
  • react @ ^0.14.0 || ^15.0.0
  • react-addons-transition-group @ ^0.14.0 || ^15.0.0
  • react-addons-css-transition-group @ ^0.14.0 || ^15.0.0
  • react-dom @ ^0.14.0 || ^15.0.0
4.0.0 - 4.5.0
  • react @ ^0.14.0 || ^15.0.0
  • react-addons-css-transition-group @ ^0.14.0 || ^15.0.0
  • react-addons-transition-group @ ^0.14.0 || ^15.0.0
  • react-dom @ ^0.14.0 || ^15.0.0
4.6.0 - 4.7.0
  • react @ ^0.14.9 || ^15.3.0
  • react-transition-group @ ^1.1.2
  • react-dom @ ^0.14.9 || ^15.3.0
4.8.0
  • react @ ^0.14.9 || ^15.3.0
  • react-transition-group @ ^1.1.2
  • react-dom @ ^0.14.9 || ^15.3.0
6.0.0 - 6.5.0
  • react @ ^16.0.0
  • react-dom @ ^16.0.0
7.0.0 - 7.1.0
  • react @ ^16.0.0
  • react-dom @ ^16.0.0
8.0.0 - 8.6.0
  • react @ ^16.3.0
  • react-dom @ ^16.3.0
8.7.0 - 8.9.0
  • react @ >=16.3.0
  • react-dom @ >=16.3.0