sass-loader versions and peer dependencies

The table below has a list of all versions of sass-loader compatible peers dependencies.

Version Peer Dependency Versions
1.0.0
  • node-sass @ ^3.0.0-alpha.0
1.0.1
  • node-sass @ ^3.0.0-beta.4
1.0.2 - 1.0.4
  • node-sass @ ^3.1.0
2.0.0 - 2.0.1
  • node-sass @ ^3.2.0
3.0.0 - 3.1.1
  • node-sass @ ^3.3.3
  • webpack @ ^1.12.2
3.1.2 - 3.2.0
  • node-sass @ ^3.4.2
  • webpack @ ^1.12.6
3.2.1 - 3.2.3
  • node-sass @ ^3.4.2
  • webpack @ ^1.12.6 || ^2.1.0-beta
4.0.0 - 4.0.2
  • node-sass @ ^3.4.2
  • webpack @ ^1.12.6 || ^2.1.0-beta
4.1.0
  • node-sass @ ^3.4.2 || ^4.0.0
  • webpack @ ^1.12.6 || ^2.1.0-beta
4.1.1
  • node-sass @ ^3.4.2 || ^4.0.0
  • webpack @ ^1.12.6 || ^2.1.0-beta
5.0.0 - 5.0.1
  • node-sass @ ^4.0.0
  • webpack @ ^2.0.0
6.0.0 - 6.0.5
  • node-sass @ ^4.0.0
  • webpack @ ^2.0.0
6.0.6
  • node-sass @ ^4.0.0
  • webpack @ ^2.0.0 || >= 3.0.0-rc.0 || ^3.0.0
6.0.7
  • node-sass @ ^4.0.0
  • webpack @ ^2.0.0 || >= 3.0.0-rc.0 || ^3.0.0
7.0.0 - 7.3.1
  • webpack @ ^3.0.0 || ^4.0.0
8.0.0
  • webpack @ ^4.36.0
  • node-sass @ ^4.0.0
  • sass @ ^1.3.0
  • fibers @ >= 3.1.0
8.0.1 - 8.0.2
  • webpack @ ^4.36.0 || ^5.0.0
  • node-sass @ ^4.0.0
  • sass @ ^1.3.0
  • fibers @ >= 3.1.0
9.0.0 - 9.0.3
  • webpack @ ^4.36.0 || ^5.0.0
  • node-sass @ ^4.0.0
  • sass @ ^1.3.0
  • fibers @ >= 3.1.0
10.0.0 - 10.0.4
  • webpack @ ^4.36.0 || ^5.0.0
  • node-sass @ ^4.0.0
  • sass @ ^1.3.0
  • fibers @ >= 3.1.0
10.0.5 - 10.1.1
  • webpack @ ^4.36.0 || ^5.0.0
  • node-sass @ ^4.0.0 || ^5.0.0
  • sass @ ^1.3.0
  • fibers @ >= 3.1.0
11.0.0
  • webpack @ ^5.0.0
  • node-sass @ ^4.0.0 || ^5.0.0
  • sass @ ^1.3.0
  • fibers @ >= 3.1.0
11.0.1
  • webpack @ ^5.0.0
  • node-sass @ ^4.0.0 || ^5.0.0
  • sass @ ^1.3.0
  • fibers @ >= 3.1.0