semantic-ui-react versions and peer dependencies

The table below has a list of all versions of semantic-ui-react compatible peers dependencies.

Version Peer Dependency Versions
0.53.0 - 0.74.2
  • react @ >=0.14.0 <= 15
  • react-dom @ >=0.14.0 <= 15
0.75.0 - 0.81.3
  • react @ >=0.14.0 <= 16
  • react-dom @ >=0.14.0 <= 16
0.82.0 - 0.83.0
  • react @ ^16.0.0
  • react-dom @ ^16.0.0
0.84.0 - 0.87.3
  • react @ ^16.3.0
  • react-dom @ ^16.3.0
0.88.0 - 0.88.2
  • react @ ^16.8.0
  • react-dom @ ^16.8.0
1.0.0 - 1.3.1
  • react @ ^16.8.0
  • react-dom @ ^16.8.0
2.0.0 - 2.0.1
  • react @ ^16.8.0
  • react-dom @ ^16.8.0
2.0.2 - 2.0.3
  • react @ ^16.8.0 || ^17.0.0
  • react-dom @ ^16.8.0 || ^17.0.0