styled-components versions and peer dependencies

The table below has a list of all versions of styled-components compatible peers dependencies.

Version Peer Dependency Versions
1.0.7 - 1.4.6
  • react @ ^0.14.0 || ^15.0.0-0
2.0.0 - 2.1.0
  • react @ ^0.14.0 || ^15.0.0-0
2.1.1 - 2.4.1
  • react @ >= 0.14.0 < 17.0.0-0
3.0.1 - 3.4.10
  • react @ >= 0.14.0 < 17.0.0-0
4.0.0
  • react @ >= 16.3.0
4.0.1 - 4.4.1
  • react @ >= 16.3.0
  • react-dom @ >= 16.3.0
5.0.0 - 5.2.1
  • react @ >= 16.8.0
  • react-dom @ >= 16.8.0
  • react-is @ >= 16.8.0