ts-node versions and peer dependencies

The table below has a list of all versions of ts-node compatible peers dependencies.

Version Peer Dependency Versions
8.0.0 - 8.5.4
  • typescript @ >=2.0
8.6.0 - 8.10.2
  • typescript @ >=2.7
9.0.0 - 9.1.1
  • typescript @ >=2.7