webpack-dev-middleware versions and peer dependencies

The table below has a list of all versions of webpack-dev-middleware compatible peers dependencies.

Version Peer Dependency Versions
0.10.1 - 0.10.2
  • webpack @ 0.10.x
0.11.0
  • webpack @ 0.10.x
1.0.0 - 1.1.0
  • webpack @ 1.x
1.2.0 - 1.3.0
  • webpack @ ^1.0.0
1.4.0 - 1.5.1
  • webpack @ >=1.0.0 <3
1.6.0 - 1.8.4
  • webpack @ 1 || ^2.1.0-beta
1.9.0 - 1.10.2
  • webpack @ 1 || ^2.1.0-beta || ^2.2.0-rc.0
1.11.0 - 1.12.2
  • webpack @ ^1.0.0 || ^2.0.0 || ^3.0.0
2.0.0 - 2.0.4
  • webpack @ ^2.2.0 || ^3.0.0 || ^4.0.0-alpha
2.0.5 - 2.0.6
  • webpack @ ^2.2.0 || ^3.0.0 || ^4.0.0-alpha || ^4.0.0-beta || ^4.0.0
3.0.0 - 3.1.0
  • webpack @ ^4.0.0
3.1.1
  • chalk @ ^2.1.0
  • webpack @ ^4.0.0
3.1.2 - 3.7.2
  • webpack @ ^4.0.0
3.7.3
  • webpack @ ^4.0.0
4.0.0 - 4.2.0
  • webpack @ ^4.0.0 || ^5.0.0